[CoovaChilli] Coovachilli login does nothing (login.chi redirection doesn't work)

Brian Andrews brian at andrews.org.nz
Sun Jun 19 04:56:18 BST 2016


Do you have haserl installed?

> On 18/06/2016, at 7:41 AM, Tanmaya Mishra <tanu1409 at gmail.com> wrote:
> 
> Hello!
> 
> My setup is so:
> 
> 1) A Raspberry Pi connected to a TPLink Router over Wifi (br-lan)
> 
> 2) A FreeRadius server runs on the Pi. I have CoovaChilli installed on the
> Router.
> 
> 3) The Wifi (br-lan) interface is where clients will connect. The wan
> interface is usb0.
> 
> When I launch the radius server on the Pi and then the Coova chilli
> instance on the router, I receive an Accounting-Request packet on the
> FreeRadius server from coovachilli, so it seems the connection is perfectly
> fine.
> 
> When I try accessing google on my laptop, connected to the br-lan
> interface, I am successfully redirected to the default coovachilli login
> page.
> 
> However, when I enter the credentials and press login, I am immediately
> shown the Connection Reset error (Firefox, URL in the browser is
> 192.168.1.1:4990/www/login.chi). I also receive nothing on my FreeRadius
> server, suggesting that nothing was sent.
> 
> Would be very grateful for any suggestions/hints.
> 
> Thank you
> Ghantaz
> _______________________________________________
> CoovaChilli mailing list
> CoovaChilli at brightonchilli.org.uk
> https://www.brightonchilli.org.uk/mailman/listinfo/coovachilli



More information about the CoovaChilli mailing list