[CoovaChilli] Unable to connect to internet after installing coovachilli

Surya Teja suryateja042 at gmail.com
Fri Apr 26 10:42:45 BST 2019


Hi,
I have installed the coova-chili and its respective dependency packages on
plane *centos7*. I have followed the below reference link
https://www.howtoforge.com/tutorial/how-to-install-a-wireless-hotspot-with-captive-page-in-linux-using-coovachilli/
I have configured the network in the */etc/chilli/config* file as below

HS_WANIF=eno1 # WAN Interface toward the Internet
HS_LANIF=wlo1 # Subscriber Interface for client devices
*HS_NETWORK=10.1.0.0* # HotSpot Network (must include HS_UAMLISTEN)
HS_NETMASK=255.255.255.0 # HotSpot Network Netmask
HS_UAMLISTEN=10.1.0.1 # HotSpot IP Address (on subscriber network)
HS_UAMPORT=3990 # HotSpot UAM Port (on subscriber network)
HS_UAMUIPORT=4990 # HotSpot UAM "UI" Port (on subscriber network, for
embedded portal)

HS_DNS1=8.8.8.8
HS_DNS2=8.8.8.8

I have started all the services and when I tried to connect the network
10.1.0.0 (my captive portal network) through my phone. Coova-chilli dhcpd
offered an IP to my phone that's good but when I am searching for anything
on the internet it is not redirecting to portal page(issue 1)
and I tried to open 10.1.0.1:4990 it redirected me to portal login page
asked me for validating the user, I have logged in with the credentials
which I have stored in freeradius DB it accepted it and I got the success
message, but still am I unable to connect to the internet(Issue2). can
anyone help me in getting out these *2 issues*?

and *my ifconfig is as follows*

* ===========================================*

*[root at ws2012 ~]# ifconfig*

*eno1: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500*

*        inet 192.168.0.133  netmask 255.255.255.0  broadcast 192.168.0.255*

        inet6 2018:2018::58  prefixlen 128  scopeid 0x0<global>

        inet6 fe80::f719:e17e:f317:4ce7  prefixlen 64  scopeid 0x20<link>

        ether 94:57:a5:da:cc:78  txqueuelen 1000  (Ethernet)

        RX packets 8747  bytes 590732 (576.8 KiB)

        RX errors 0  dropped 0  overruns 0  frame 0

        TX packets 826  bytes 161984 (158.1 KiB)

        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0


lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536

        inet 127.0.0.1  netmask 255.0.0.0

        inet6 ::1  prefixlen 128  scopeid 0x10<host>

        loop  txqueuelen 1000  (Local Loopback)

        RX packets 304  bytes 30027 (29.3 KiB)

        RX errors 0  dropped 0  overruns 0  frame 0

        TX packets 304  bytes 30027 (29.3 KiB)

        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0


*tun0: flags=81<UP,POINTOPOINT,RUNNING>  mtu 1500*

*        inet 10.1.0.1  netmask 255.255.255.0  destination 10.1.0.1*

        inet6 fe80::773c:f591:13dd:925d  prefixlen 64  scopeid 0x20<link>

        unspec 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00  txqueuelen
100  (UNSPEC)

        RX packets 42  bytes 3226 (3.1 KiB)

        RX errors 0  dropped 0  overruns 0  frame 0

        TX packets 7  bytes 448 (448.0 B)

        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0


*wlo1: flags=4419<UP,BROADCAST,RUNNING,PROMISC,MULTICAST>  mtu 1500*

        inet6 fe80::626d:c7ff:fe2b:195b  prefixlen 64  scopeid 0x20<link>

        ether 60:6d:c7:2b:19:5b  txqueuelen 1000  (Ethernet)

        RX packets 170  bytes 25170 (24.5 KiB)

        RX errors 0  dropped 0  overruns 0  frame 0

        TX packets 145  bytes 26858 (26.2 KiB)

        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0


*[root at ws2012 ~]# *
=========================================
Any help would be appreciated.

Thanks
surya


More information about the CoovaChilli mailing list